We identified that recent call quality and service degradation issues were caused by packet loss from one of our upstream carriers. To mitigate the impact, we have temporarily disabled our connection to the affected link and rerouted traffic through alternate paths.
Service has been stabilized, and we are closely monitoring performance. Once our carrier confirms the issue is fully resolved, we will schedule an after-hours maintenance window to safely restore the original connection.
Posted Oct 14, 2025 - 12:28 EDT
Update
Our Engineering team has engaged with our upstream provider, investigation is still ongoing.
Posted Oct 14, 2025 - 12:00 EDT
Update
Our Engineering team is continuing to investigate this issue.
Posted Oct 14, 2025 - 11:27 EDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2025 - 10:57 EDT
Investigating
We are aware that some customers are reporting degraded Call Quality and, in some cases, Call-Parking issues. This seems to be affecting some of our Business Voice and Switchvox customers. Our engineering team is actively investigating the matter. Right now, there looks to be packet loss between some of our upstream links, and we are looking into this issue with our providers and exploring options to redirect around the loss.
Posted Oct 14, 2025 - 10:27 EDT
This incident affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice), Voice Services (Business Voice+)) and Switchvox Cloud Unified Communications Platform (UCaaS) (Voice Services (Switchvox Cloud)).