Inbound/Outbound Call issues - Switchvox Cloud

Incident Report for Sangoma

Resolved

This incident has now been resolved.
Posted Jul 01, 2026 - 17:09 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2026 - 13:23 EDT

Update

Our Engineers are continuing to investigate and troubleshoot this issue.
Posted Jul 01, 2026 - 12:53 EDT

Investigating

We are noticing a small subset of Switchvox Cloud customers are having issues with outbound call completion. Our Engineers are currently investigating this issue.
Posted Jul 01, 2026 - 12:04 EDT
This incident affected: Switchvox Cloud Unified Communications Platform (UCaaS) (Voice Services (Switchvox Cloud)).