Portal Issue - Portal.Sangoma Unreachable

Incident Report for Sangoma

Resolved

This incident is now resolved.
Posted Jun 16, 2026 - 02:17 EDT

Monitoring

Our Engineers identified the source of the trouble and have implemented a fix. We're now monitoring the results.
Posted Jun 16, 2026 - 01:07 EDT

Investigating

We have discovered an issue with Portal.Sangoma currently being unreachable. Our Engineering team is actively investigating this issue.
Posted Jun 15, 2026 - 23:39 EDT
This incident affected: Sangoma Website, Portals and Stores (Sangoma Portal (portal.sangoma.com)).