store.sipstation.com portal Maintenance Window: May 14th

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted May 14, 2026 - 09:51 EDT

Investigating

During this maintenance window, we will be performing essential updates and improvements to enhance the stability and performance of store.sipstation.com portal. As a result, the portal may experience temporary downtime or reduced functionality.
Posted May 14, 2026 - 09:09 EDT
This incident affected: Sangoma Website, Portals and Stores (SIPStation Store (store.sipstation.com)).