Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 28, 2025 - 05:00 EDT
Scheduled
Details and Scope: Sangoma will be performing regularly scheduled maintenance on our platforms. Impact: During the deployment window, select customers may experience delays in saving changes to BV Portal. Certain Business Voice extensions may temporarily lose registration/ re-register within 3 seconds, but this will NOT impact active calls. There is no expectation of any other service interruption or degradation. All other calls and services are expected to continue as normal. Time of Release: Scheduled for Thursday August 28th at 5:00 AM Eastern Time Duration: Expected to be no longer than a 60-minute window
Posted Aug 27, 2025 - 13:48 EDT
This scheduled maintenance affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice), Voice Services (Business Voice+)).