Faxstation Portal not displaying faxes

Incident Report for Sangoma

Resolved

We have been monitoring this incident and we are seeing no issues. This case will now be closed.

Feel free to contact us with any questions or concerns.
Posted Apr 22, 2025 - 16:14 EDT

Monitoring

Our engineers have put a fix in. If you are still experiencing the problem, log out, clear your browser's cache, and log back in. If that does not resolve the issue contact support.
Posted Apr 22, 2025 - 12:10 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2025 - 11:59 EDT

Investigating

We are aware of an issue with the Faxstation portal intermittently not displaying faxes in Inbox or Outbox. Our engineers are aware and are looking into the cause and resolution.
Posted Apr 22, 2025 - 11:50 EDT
This incident affected: Sangoma Website, Portals and Stores (FAXStation Portal (fax.sipstation.com)).