Converted VVX Polycom phones registration issues - BV+

Incident Report for Sangoma

Resolved

This issue has been resolved. If you still have a phone experiencing this firmware issue, please resch out to Support directly and they will be able to assist.
Posted Feb 25, 2026 - 09:08 EST

Identified

Our engineering team has identified the issue and is working on a resolution. If you are experiencing this issue, contact support and they will work with you on getting your phones configured and working.
Posted Feb 24, 2026 - 19:29 EST

Update

We are still continuing to investigate this issue and will keep you updated.
Posted Feb 24, 2026 - 19:21 EST

Investigating

Our Engineers are investigating a small subset of BV+ customers with converted VVX Polycom phones on firmware less than 5.9.3 might be experiencing registration issues.
Posted Feb 24, 2026 - 18:24 EST
This incident affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice), Voice Services (Business Voice+)).