Call Distribution Issue - CX

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 15:00 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2026 - 13:51 EST

Investigating

We have discovered an issue with incoming call distribution that is currently affecting a subset of CX users. Our engineering team is actively investigating the matter.
Posted Jan 05, 2026 - 13:36 EST
This incident affected: CommUnity Unified Communications Platform (UCaaS) (Sangoma CX (CommUnity)).