Call Delivery Issue - BV Users

Incident Report for Sangoma

Resolved

This incident is now being resolved.
Posted Sep 02, 2026 - 15:31 EDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Sep 02, 2026 - 12:41 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2026 - 12:17 EDT

Investigating

Our Engineers are investigating an issue where BV users with integrated CX extensions might be experiencing issues with call delivery.
Posted Sep 02, 2026 - 12:02 EDT
This incident affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice)) and Contact Center as a Service (CCaaS) (Sangoma CX).