Portals Degraded - Digium Cloud Services

Incident Report for Sangoma

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2026 - 16:05 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2026 - 15:58 EDT

Investigating

We have discovered an issue with loss of some functionality that is currently affecting Digium Cloud Services portals. Our engineering team is actively investigating the matter.
Posted Aug 26, 2026 - 15:20 EDT
This incident affects: Sangoma Website, Portals and Stores (Switchvox Portal (my.digiumcloud.com), Switchvox Cloud Onboarding Wizard (welcome.digiumcloud.com)).