Voicemail access issue - BV & BV+

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 12:48 EDT

Monitoring

Our Engineers identified an issue with accessing voicemail that impacted a small subset of BV & BV+ customers. They have implemented a fix and we are now monitoring the results.
Posted Jul 22, 2026 - 10:33 EDT
This incident affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice), Voice Services (Business Voice+)).