Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2025 - 21:30 EDT
Scheduled
Description and scope: On 07/08/2025 at 9:30 pm EDT we will be performing a scheduled intervention for the Sangoma Meet platform.
Intervention duration: 120 minutes
Impact: Sangoma Meet services will be impacted during the maintenance period.
Considerations: - This is a routine maintenance release focused on enhancing the stability, reliability, and overall performance of your Sangoma Meet application.
Bug Fixes: - Meeting roles now reliably correct - Screen recordings always capture current view - Live captions consistently appear on screen - All participant audio now fully recorded - Teamhub summaries display accurately - Transcription starts and stops reliably
Posted Jul 07, 2025 - 10:47 EDT
This scheduled maintenance affected: Collaboration as a Service (Sangoma Meet).