Error when Registering New Users - Sangoma Talk & Desktop / Sangoma Connect

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 15:59 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2026 - 12:39 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 06, 2026 - 11:48 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2026 - 11:14 EST

Investigating

We are aware that some customers are experiencing a failure along with an error message when trying to register a new user on Sangoma Talk Mobile/Desktop or Sangoma Connect. The platform is still working and remains available. This is only impacting new user registration. Our engineering team is actively investigating the matter.
Posted Feb 06, 2026 - 10:58 EST
This incident affected: Collaboration as a Service (Sangoma Talk).