Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 07, 2026 - 21:00 EDT
Scheduled
Details and Scope: Sangoma will be performing regular maintenance on the Business Voice platform. Impact: Select Business Voice Plus customers (with remote extensions) may experience a loss of registration. During the deployment window, a subset of Business Voice customers may also experience temporary disruptions affecting BV Basic Queues and Call Parking functionality. There is no expectation of any other service interruption or degradation. All other calls and services are expected to continue as normal. Time of Release: Scheduled for Tuesday 07/07/2026 at 9:00 PM ET Duration: Expected to be a 60 minute window
Posted Jul 06, 2026 - 12:16 EDT
This scheduled maintenance affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice), Voice Services (Business Voice+)).