Incoming Call Issue - Sangoma Talk

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted May 04, 2026 - 16:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 14:38 EDT

Update

Our engineers have confirmed that this is an issue with a 3rd party vendor. They are currently working with their engineers to identify and resolve the issue.
Posted May 04, 2026 - 13:41 EDT

Investigating

We have discovered an issue with incoming calls to iOS users that is currently affecting Sangoma Talk. Calls are not coming in if Sangoma Talk is open in the background but not the active app on the device. Our engineering team is actively investigating the matter.
Posted May 04, 2026 - 13:04 EDT
This incident affected: Collaboration as a Service (Sangoma Talk).