Calls Not Processing Issue - CX

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 14:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 13:16 EDT

Update

A fix is being implemented and systems are recovering.
Posted Jul 16, 2026 - 13:05 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 16, 2026 - 12:55 EDT

Update

After investigation our engineers have found that the only issue is the call records are not showing in the portal. We are continuing to investigate the cause.
Posted Jul 16, 2026 - 12:24 EDT

Investigating

We have discovered an issue with calls not being processed to available agents that is currently affecting CX. Our engineering team is actively investigating the matter.
Posted Jul 16, 2026 - 12:19 EDT
This incident affected: Contact Center as a Service (CCaaS) (Sangoma CX).