Email Notification Issue - Multiple Services

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 16:07 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2026 - 10:03 EDT

Investigating

We have discovered an issue with email notifications that is currently affecting multiple services. Our engineering team is actively investigating the matter.
Posted Jul 28, 2026 - 09:44 EDT
This incident affected: Sangoma Website, Portals and Stores (Sangoma Portal (portal.sangoma.com), SIPStation Store (store.sipstation.com), Switchvox Portal (my.digiumcloud.com)).