Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 28, 2025 - 21:01 EDT
Scheduled
Description and scope: On 08/28/2025 at 9:30 pm EDT we will be performing a scheduled intervention for the Sangoma Meet platform.
Intervention duration: 120 minutes
Impact: Sangoma Meet services will be impacted during the maintenance period.
Considerations: - This is a routine maintenance release focused on enhancing the stability, reliability, and overall performance of your Sangoma Meet application.
Enhancement and Bug Fixes: - Improved Meeting Security for Dial-In Users - Enhanced User Experience for Terms of Service - Fixed a critical one-way audio issue - Fixed an error that could prevent the successful download of the Windows desktop application - Fixed a UI bug where the "unmute" label for dial-in users was not updating - Added user feedback for participants who attempt to screen share while in a low-bandwidth
Posted Aug 27, 2025 - 15:30 EDT
This scheduled maintenance affected: Collaboration as a Service (Sangoma Meet).