Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2025 - 02:30 EDT
Scheduled
Sangoma Engineering has scheduled a Maintenance window for Thursday 4/24/2025 beginning @ 2:30AM ET at San Francisco datacenter facility. This maintenance window is planned for 60 minutes. The services to customers should not be impacted except the monitoring system might show connections down. They will be performing the monitoring system and other server's internet path changes at the datacenter. This maintenance is part of our continued network upgrades to increase network reliability and ensure proper security and stability. Your business with us is valued and we sincerely appreciate your patience for any inconvenience this may cause.
Posted Apr 16, 2025 - 15:58 EDT
This scheduled maintenance affected: Managed Service Provider (MSP) (Internet Access / Circuits, SD-WAN, Security Services, Managed Network Services).