A fix has been made and portals and stores have been restored. We'll be monitoring the results.
Posted May 31, 2026 - 22:03 EDT
Update
We are continuing to work with our upstream provider to resolve the issue.
Posted May 31, 2026 - 19:47 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 31, 2026 - 17:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 31, 2026 - 17:55 EDT
Investigating
We have discovered an issue with multiple portals that is currently affecting SIPstation, Faxstation, PBXact, and Switchvox. This is being caused by an issue with an upstream provider. Our engineering team is actively investigating the matter with the upstream provider.
Posted May 31, 2026 - 17:33 EDT
This incident affected: Sangoma Website, Portals and Stores (FAXStation Portal (fax.sipstation.com), PBXact Cloud Portal (cloud.pbxact.com), Sangoma Customer Support (support.sangoma.com), Sangoma Portal (portal.sangoma.com), SIPStation Store (store.sipstation.com)).