Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 06, 2026 - 21:00 EST
Scheduled
Details and Scope: Sangoma will be performing regularly scheduled maintenance on our Business Voice platform. There are also planned updated for the TeamHub platform and additional details can be found here: https://sangomakb.atlassian.net/wiki/x/HYLRAQ. Impact: There may be select Business Voice Plus customers (NAT’d StarBoxes) that may experience two way audio issues during the deployment window. There is no expectation of any service interruption or degradation. All calls and services are expected to continue as normal. Time of Release: Scheduled for Tuesday 01/06/2026 at at 9:00 PM ET Duration: Expected to be a 60 minute window
Posted Jan 05, 2026 - 12:19 EST
This scheduled maintenance affected: Business Voice Unified Communications Platform (UCaaS) (Voice Services (Business Voice), Voice Services (Business Voice+), Sangoma CX (Business Voice)), Collaboration as a Service (TeamHub Web, TeamHub Desktop), and CommUnity Unified Communications Platform (UCaaS) (Sangoma CX (CommUnity)).