The portal remains stable at this time. Availability of the fax platform was not disrupted. We will continue to monitor performance for continued portal stability.
Posted Nov 11, 2025 - 20:07 EST
Identified
We have observed that this issue occurs intermittently. Our engineering team is working on implementing a permanent fix.
Posted Nov 11, 2025 - 15:38 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 13:12 EST
Update
We are continuing to investigate this issue.
Posted Nov 11, 2025 - 11:22 EST
Update
We’ve confirmed that this issue only impacts access to the portal. Sending and receiving faxes should continue to function normally. Our team is actively working to resolve the problem.
Posted Nov 11, 2025 - 10:24 EST
Investigating
We’ve identified an issue preventing access to the fax.netfortris.com portal, which is currently showing an error that the site cannot be reached. Our engineering team is actively working to resolve the problem.
Posted Nov 11, 2025 - 09:39 EST
This incident affected: Sangoma Website, Portals and Stores (Netfortris Efax (fax.netfortris.com)).