Calls Dropping - Sangoma CX

Incident Report for Sangoma

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 14:07 EST

Monitoring

Our engineers have isolated the issue with a third party vendor and all services have been restored. We are continuing to monitor the service to ensure it remains stable and are working with the third party vendor to determine the cause and ensure it is fully resolved.
Posted Nov 12, 2025 - 11:52 EST

Update

Services have been restored. We are continuing to investigate the cause.
Posted Nov 12, 2025 - 11:36 EST

Investigating

We have discovered an issue with calls dropping as well as difficulties connecting to the portal that is currently affecting Sangoma CX. Our engineering team is actively investigating the matter.
Posted Nov 12, 2025 - 11:21 EST
This incident affected: Business Voice Unified Communications Platform (UCaaS) (Sangoma CX (Business Voice)).